Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
461 Posts
Discussion Starter · #1 ·
imported post

hi all. just replaced my water pump on my 1100 and i got a small oil leak thru the weep
hole. i noticed there is an o-ring indent on the tranny cover itself but every picture i
see related to the installation of these o-rings show the o-rings going on the pump
itself before install. [what is up with that] i vote for the indent on the back of the tranny
cover what do you guys think? also should i silicone the rings before install?

thx
 

·
Premium Member
Joined
·
5,734 Posts
imported post

i would not do that ! too much of a danger of getting a bit of it in the oil or water and pluging some thing up .
 

·
Premium Member
Joined
·
237 Posts
imported post

I did use some silicone sealant when I replaced mine. On just about everything. I had an aftermarket gasket kit that did not inspire confidence. I have no leaks.

Did you replace the seal on the little shaft that drives the water pump?
 

·
Premium Member
Joined
·
5,734 Posts
imported post

yes ---lube the o rings on the pump body. also the pump shaft , helps the seal in the case . if everything is lined up it should all go togather with out a lot of force. you most likeley have to turn the pump shaft to get the slotted end to mesh with the pump drive.
 

·
Premium Member
Joined
·
461 Posts
Discussion Starter · #6 ·
imported post

hi. there is an o-ring indent on the back of the tranny cover do you put the o-ring there
or on the shaft itself? how much silicon did you use and where did you put it?
 

·
Premium Member
Joined
·
4,328 Posts
imported post

Oil can leak from three places the crush washers , the oil seal on the shaft and the o ring..note I put the o ring on the pump and insert into the case..also the o ring that usually gets pinched the water side not the oil side
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top