Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Premium Member
Joined
·
57 Posts
Discussion Starter #1
imported post

The following photo was taken before I replaced the trunk latch which was broken on the left side. But even now that it closes and latches properly am fairly certain I am missing some kind of trim piece where the lid meets the trunk. I tried looking at a parts diagram online but could not identify what's missing

Take a look.
 

Attachments

·
Premium Member
Joined
·
266 Posts
imported post

It looks to me as though the lid is not seated down properly. It appears that there is a gap along the side as well as the rear. Perhaps the lid needs to "slide down" in the hinges?

There is no such additional piece on my 93, the lid simply fits to the trunk itself.
 

·
It aint rocket science
Joined
·
3,942 Posts
imported post

Beautiful bike.

The top is not aligned correctly fore and aft.

You can see it in the vertical chrome trim on the front of the box, which does not line up.

JD
 

·
Premium Member
Joined
·
57 Posts
Discussion Starter #4
imported post

Thanks guys. Now knowing that there was nothing missing I found the problem. It was the metal tabs on the lid that catch in the latch on the trunk, they were sticking out too much. I loosen the screws and "shortened" the tabs and now the gap is gone!

Thanks again
 

·
Vintage Rider
Joined
·
2,410 Posts
imported post

Yep, that is a beautiful bike. I just love that color.
 

·
Premium Member
Joined
·
80 Posts
imported post

the only thing missing i see a rider on a sweet ride screeming YEE HAW in the twisties,oh and a little adjustment on some trunk latches
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top