Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Premium Member
Joined
·
9 Posts
Discussion Starter #1
imported post

When I try to start the bike all that happen's is a clicking noise in the main fuse. The battery was run down, so I pulled it and charged it, then I went to start it but it just barely turned over, so I used the power boost on my charger, and it almost started, so I had to reset the power boost, but then the clicking started. Any Idea's welcome!!!! It's agrand day here, perfect for riding, but what did I mess up? First Timer Austin, Tx
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #3
imported post

Thanks for your reply. Are you prior Navy? I served in the old school "Vietnam Conflict", in the 62 SPS, (MAC) Military Airlift Command, out of McCord AFB,Tacoma Wa.. We were doingEVAC out of Vietnam, and Thiland,and I just liked to say God bless your son, and the rest of your familyas well.



First Timer
 

·
Premium Member
Joined
·
3,391 Posts
imported post

Have your battery load tested after charging.
Only after you have a known good battery can you then diagnose any problems.
 

·
Premium Member
Joined
·
9 Posts
Discussion Starter #5
imported post

Thank's, I already have the battery on the charger now, for a long slow trickle charge. I was kind of thinking of doing that already. I think that because some kid's had turned the cb on and ran the battery down and then we had a cold spell, that it may have killed it, so I was going to charge it and have the CCA's checked.

Once again thank you.



First Timer
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top