Steve Saunders Goldwing Forums banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Premium Member
Joined
·
276 Posts
Discussion Starter #1
imported post

Looks like the ignition switch on my 84 GL1200A is finally giving up the ghost.

It's getting sloppy, and I gotta wiggle it to get it into position.

Haven't had a problem with it 'slipping' and turning off while riding, and don't want to.



I've been looking at some sites, but, can't seem to find what I'm looking for.



Anyone got one, or a good link to where I might get one (for a fair price).



Thanx



Dave
 

·
Premium Member
Joined
·
12 Posts
imported post

Hi Dave,



I had the exact same thing happen this week, and while looking around I thought do I really want to waste money on a used switch that may fail in a short time period.



Called local dealer, they were able to get brand new one for 140, I am in Canada, so that would be about 105 us



Honda Canada still has one in stock.



Dan
 

·
Premium Member
Joined
·
276 Posts
Discussion Starter #3
imported post

Dan
Yea, my local mechanic said he could get one from the dealer for $120. I looked and looked, and decided new is better than used. And the posibility of the thing shutting down at 80MPH while going around a large swooping curve, with the girlfriend on back, didn't impress me.
Taking it to him on Sat.

Sorry to hear of your same unfortunate experience, but, then again, better to find out now, than say, on a 5000 KM road trip in the mmiddle of nowhere.

Have a great riding season

Dave
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top